Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted May 18, 2026 - 08:44 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 14, 2026 - 15:45 AEST
Scheduled
There is a change implementation process occurring in the public website www.chisholm.edu.au from the 14/05/2026 9:00am until the 18/05/2026 17:00. During this change implementation process, there might be slowness on the website for a minute or two for the public website users.
Posted May 14, 2026 - 15:34 AEST
This scheduled maintenance affected: Systems (WEB Site).