Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 12, 2024 - 07:00 AEDT
Scheduled
Construction work on the Building C Cafeteria will be undertaken from Tuesday 12th to Monday 18th November. This project may generate some construction noise during this time.
Posted Nov 07, 2024 - 12:11 AEDT
This scheduled maintenance affected: Facilities (Frankston).