APPLICATION OUTAGE - MICROSOFT 365 APPLICATIONS [ALL CAMPUSES]

Incident Report for chisholm

Update

We are still investigating the Microsoft licensing issue affecting MS 365 Office applications. Web-based apps are available as a workaround. Logged ServiceNow tickets are being actioned.
Posted Apr 27, 2026 - 11:48 AEST

Investigating

Some staff and students are experiencing issues with Microsoft 365 Applications. ITS are currently investigating and updates will be provided once further information is known.
Posted Apr 27, 2026 - 09:27 AEST
This incident affects: Systems (Microsoft365).