Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 27, 2025 - 07:00 AEST
Scheduled
Due to the construction of the new car park, there will be NO ACCESS to the road between Building C and Buildings D and F at Dandenong campus. (Forklift access is permitted by appointment)
- Construction hours are 7:00am to 4:00pm Monday to Friday - Temporary fencing will be installed around the construction zone - DDA parking spaces closest to the site will remain available - Noise and dust are expected during construction - Project completion is scheduled for September 2025.
Project updates will be provided on the Intranet. Please email majorprojects@chisholm.edu.au if you have any questions.
Posted Aug 26, 2025 - 12:40 AEST
This scheduled maintenance affects: Facilities (Dandenong) and Projects (Dandenong Re-Stack Project).