Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 23, 2025 - 07:00 AEDT
Scheduled
Planned maintenance on STRATA has been scheduled for Thursday 23 October from 7:00am to 7:30am. All STRATA functionality and its portals will be offline during this period.
Posted Oct 20, 2025 - 15:29 AEDT
This scheduled maintenance affected: Systems (Strata).