RESTRICTED ACCESS - KELSO STREET PARKING [FRANKSTON]
Scheduled for Nov 13, 07:00 - 17:00 AEDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 12, 2025 - 08:10 AEDT
Scheduled
Access to the Kelso Street car parks adjacent to Building R at Frankston campus will be unavailable from 7:00am to 5:00pm Thursday 13 November to allow for scheduled works. There will be large trucks in the area, please follow all traffic management personnel and signage. The staff car park remains open for use during this time.
Posted Nov 13, 2025 - 07:00 AEDT
This scheduled maintenance affects: Projects (Frankston Redevelopment Project Stage 3) and Facilities (Frankston).