Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 25, 2025 - 06:00 AEDT
Scheduled
Access to Buildings R and S at Dandenong campus will be restricted from 6:00am to 7:00pm Saturday 25 October to allow for scheduled cabling installation. The Comms room and thoroughfares will be impacted. Minimal noise will occur during these works.
Posted Oct 20, 2025 - 12:54 AEDT
This scheduled maintenance affected: Facilities (Dandenong).