Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 09, 2025 - 07:00 AEDT
Scheduled
Access to the new Central car park at Dandenong campus will be unavailable from 7:00am Thursday 9 October to 4:00pm Saturday 11 October to allow for light installation and cabling works. There will be NO ACCESS to the car park during this time.
Posted Oct 03, 2025 - 08:24 AEST
This scheduled maintenance affected: Facilities (Dandenong) and Projects (Dandenong Re-Stack Project).