Please note Building B has been affected by the water outage. Services will return at 3:30pm today.
Posted Apr 17, 2026 - 15:12 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 17, 2026 - 13:00 AEST
Scheduled
The water supply to Buildings J, K, L and T at Frankston campus will be interrupted from 1:00pm to 3:30pm Friday 17 April to allow for scheduled maintenance works.
Posted Apr 17, 2026 - 11:53 AEST
This scheduled maintenance affected: Facilities (Frankston).