NO ACCESS - DA-B TOILET FACILITIES [DANDENONG]

Incident Report for chisholm

Resolved

The facilities are now operational.
Posted Jul 15, 2026 - 14:57 AEST

Identified

Access to the male and female toilets in Building B at Dandenong campus are currently unavailable. Contractors are onsite working to fix the issue. Updates will be provided once additional information is known.
Posted Jul 15, 2026 - 13:02 AEST
This incident affected: Facilities (Dandenong).