Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 09, 2025 - 07:30 AEST
Scheduled
Roof access safety inspections have been scheduled for Dandenong campus buildings from 7:30am to 4:30pm, Tuesday 9 September to Friday 12 September. Contractors will be walking on the roofs of buildings and there may be intermittent noise during this time.
Posted Sep 05, 2025 - 08:38 AEST
This scheduled maintenance affected: Facilities (Dandenong).