LIFT OUTAGE - BE-J [BERWICK]

Incident Report for chisholm

Resolved

The lift is now operational.
Posted Apr 01, 2025 - 13:04 AEDT

Investigating

Lift services in building J at Berwick campus have been interrupted due to unscheduled maintenance works. Updates will be provided when they are available.
Posted Mar 31, 2025 - 13:00 AEDT
This incident affected: Facilities (Berwick).