Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 13, 2026 - 11:00 AEDT
Scheduled
The water supply to Building R at Dandenong campus will be interrupted from 11:00 am to 2:30pm Friday 13 February to allow for scheduled maintenance works. During this time, please use toilets located on level 1 in the new part of the building.
Posted Feb 13, 2026 - 10:52 AEDT
This scheduled maintenance affected: Facilities (Dandenong).