POWER OUTAGE - MP-D [MORNINGTON PENINSULA]

Incident Report for chisholm

Resolved

Power has now been returned to building D at Mornington Peninsula campus.
Posted Apr 02, 2025 - 13:14 AEDT

Investigating

The power supply to building D at Mornington Peninsula campus has been interrupted.  The cause is currently being investigated.
Posted Apr 02, 2025 - 12:30 AEDT
This incident affected: Facilities (Mornington Peninsula).