Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 23, 2025 - 18:00 AEDT
Scheduled
Printing Services will be unavailable at Bass Coast and Mornington Peninsula campuses from 6:00pm to 9:00pm Thursday 23 October due to system upgrades.
Posted Oct 23, 2025 - 13:06 AEDT
This scheduled maintenance affected: Systems (Printing Services).