APPLICATION MAINTENANCE- MARKBOOK

Incident Report for chisholm

Resolved

This issue has been resolved.
Posted Feb 17, 2026 - 14:38 AEDT

Investigating

Markbook is experiencing connectivity issues. IT are investigating the cause. Further information will be provided once known.
Posted Feb 17, 2026 - 14:24 AEDT
This incident affected: Systems (Markbook).