Scheduled for Jun 12, 07:00 AEST - Jun 15, 15:00 AEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 11, 2026 - 15:32 AEST
Scheduled
Gutter cleaning works will be taking place on Building P at Dandenong campus on Friday 12 June and Monday 15 June from 7:00am to 3:30pm. Access to Building P may be restricted, including the Level 2 walkway between Buildings A and P. Some noise may be generated during these times. Follow all signage in the area to ensure your safety.
Posted Jun 11, 2026 - 15:31 AEST
This scheduled maintenance affects: Facilities (Dandenong).