Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 22, 2026 - 09:00 AEST
Scheduled
The water supply to Building A at Frankston campus will be interrupted between 9:00am and 9:30am Tuesday 22 September to allow for scheduled maintenance works. Toilet facilities will remain operational during this time. Taps within kitchen areas may be interrupted.
Posted Sep 22, 2026 - 08:59 AEST
This scheduled maintenance affected: Facilities (Frankston).