Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 28, 2026 - 10:00 AEST
Scheduled
Pedestrian access surrounding Buildings G, R and T will be restricted from 9:00am Tuesday 28 April to 5:00pm Wednesday 29 April to allow for scheduled landscaping works. To ensure your safety, please follow all signage in the area.
Posted Apr 28, 2026 - 09:56 AEST
This scheduled maintenance affected: Facilities (Frankston).