Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 20, 2026 - 07:00 AEDT
Scheduled
Ceiling works will be undertaken in the Library and Learning Centre at Frankston campus from 7:00am to 11:00am Friday 20 March. This project may generate some construction noise during this time.
Posted Mar 10, 2026 - 15:26 AEDT
This scheduled maintenance affected: Facilities (Frankston).