Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 28, 2025 - 06:00 AEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 24, 2025 - 12:27 AEST
Scheduled
There will be NO ACCESS to the eastern end of the carpark adjacent to Stud Road from 6:00am Monday 28 July 2025 until July 2026 due to the construction of the Dandenong Tech School. To ensure your safety, please follow all signage and traffic management in the area as changes to thoroughfares and road access have been implemented.
Posted Jul 24, 2025 - 12:22 AEST
This scheduled maintenance affects: Facilities (Dandenong) and Projects (Dandenong Tech School).