WATER OUTAGE - FR-C [FRANKSTON]

Incident Report for chisholm

Resolved

The water supply has been returned to Building C at Frankston campus.
Posted Feb 19, 2026 - 08:52 AEDT

Investigating

Water supply to Building C at Frankston campus has been interrupted due to unscheduled maintenance works. Updates will be provided once further information is known.
To access bathroom and kitchen areas, please use Building A.
Posted Feb 18, 2026 - 08:43 AEDT
This incident affected: Facilities (Frankston).