Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 11, 2025 - 06:00 AEST
Scheduled
Access to the car spaces along the north side of Building V at Dandenong campus will be unavailable from 6:00am to 12:00pm, Thursday 11 September to allow for scheduled maintenance works.
Posted Sep 10, 2025 - 13:26 AEST
This scheduled maintenance affected: Facilities (Dandenong).