Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 02, 2026 - 07:00 AEST
Scheduled
Access to the pathway adjacent to Building B and T at Frankston campus will be restricted from 7:00am to 5:00pm Tuesday 2 June to allow for scheduled maintenance works. When in the area, please follow all signage to ensure your safety.
Posted Jun 01, 2026 - 12:16 AEST
This scheduled maintenance affected: Facilities (Frankston).