Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 25, 2025 - 07:00 AEDT
Scheduled
The water supply to the toilets in Building C at Frankston campus will be interrupted from 7:00am to 7:30am Tuesday 25 November to allow for scheduled maintenance works.
Posted Nov 24, 2025 - 16:01 AEDT
This scheduled maintenance affected: Facilities (Frankston).