Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 16, 2025 - 07:00 AEST
Scheduled
Asphalting works for the new central car park adjacent to Buildings C and D at Dandenong campus will be undertaken from 7:00am Tuesday 16 September to 4:00pm Thursday 18 September. Impacts during these works include: - Increased traffic, including large trucks and construction workers - A noticeable smell may be present due to heated asphalt - Intermittent noise. Please follow all directional signage to ensure your safety.
Posted Sep 11, 2025 - 14:05 AEST
This scheduled maintenance affects: Facilities (Dandenong) and Projects (Dandenong Re-Stack Project).