SERVICE UNAVAILABLE - PRINTING [DANDENONG]

Incident Report for chisholm

Resolved

This incident has been resolved. Printing services at Dandenong campus have been restored.
Posted Oct 17, 2025 - 09:15 AEDT

Investigating

Printing services at Dandenong campus are currently unavailable. ITS are investigating the issue. Further updates will be provided when additional information is known.
Posted Oct 17, 2025 - 08:40 AEDT
This incident affected: Systems (Printing Services).