LIFT OUTAGE - CR-A [CRANBOURNE]

Incident Report for chisholm

Resolved

Lift services in Building A have now been restored.
Posted Nov 05, 2025 - 12:26 AEDT

Investigating

Lift services in Building A have been interrupted. The CSI team are working to identify the cause and implement a solution.
Posted Nov 05, 2025 - 09:09 AEDT
This incident affected: Facilities (Cranbourne).