Scheduled for Apr 20, 06:00 AEST - May 11, 17:00 AEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 20, 2026 - 14:02 AEDT
Scheduled
Access to the Library and Learning Centre in Building A at Frankston campus will be unavailable from Monday 20 April to Monday 11 May to allow for scheduled refurbishment works. Please see signage for the location of the temporary library space.
Posted Mar 20, 2026 - 06:00 AEDT
This scheduled maintenance affects: Facilities (Frankston).