LIFT OUTAGE - DA-A [DANDENONG]

Incident Report for chisholm

Resolved

Lift services in Building A at Dandenong campus are now available.
Posted Oct 22, 2025 - 10:31 AEDT

Investigating

Lift services in Building A at Dandenong campus are currently unavailable due to unscheduled maintenance works. Updates will be provided once further information is known.
Posted Oct 21, 2025 - 14:19 AEDT
This incident affected: Facilities (Dandenong).