INTERNET OUTAGE - [MORNINGTON PENINSULA]

Incident Report for chisholm

Resolved

Internet services have been returned to the Mornington Peninsula campus. ITS will continue to work with our provider to make further improvements.
Posted Sep 02, 2025 - 13:57 AEST

Investigating

Internet services are currently unavailable at Mornington Peninsula campus. ITS are investigating the issue. Updates will be provided once further information becomes available.
Posted Sep 02, 2025 - 09:52 AEST
This incident affected: Facilities (Mornington Peninsula) and Systems (Internet).