The scheduled geotechnical work in the Stud Road carpark have been postponed.
Posted Nov 14, 2024 - 15:42 AEDT
Scheduled
Access to parking spaces at the eastern end of the Stud Road car park may be restricted at times from Friday 15th to Friday 22nd November to allow for scheduled geotechnical works.
Posted Nov 14, 2024 - 15:38 AEDT
This scheduled maintenance affected: Facilities (Dandenong).