Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 30, 2026 - 11:55 AEST
Scheduled
Air-conditioning services in Buildings A, C and D at Frankston campus will be unavailable from 11:30am to 1:30pm to allow for the Join the Dots student event ceremony.
Posted Apr 30, 2026 - 11:54 AEST
This scheduled maintenance affected: Facilities (Frankston).