POWER OUTAGE - [LONSDALE ST]
Incident Report for chisholm
Resolved
The power supply to Lonsdale St campus has been restored. The CSI team will continue to monitor the system.
Posted Jul 16, 2024 - 15:40 AEST
Investigating
The power supply to Lonsdale St campus has been interrupted. The CSI team are working with the supplier to identify the cause and implement a solution.
Posted Jul 15, 2024 - 15:02 AEST
This incident affected: Facilities (Lonsdale Street).