Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 10, 2025 - 07:01 AEDT
Scheduled
Access to Building C at Dandenong campus will be restricted from 7:00am to 4:00pm Friday 10 October to allow for scheduled cabling installation. The Comms room, meeting rooms and thoroughfares will be impacted. Noise will occur during these works.
Posted Oct 06, 2025 - 09:10 AEDT
This scheduled maintenance affected: Facilities (Dandenong) and Projects (Dandenong new car park).