WATER OUTAGE - DANDENONG CAMPUS EXCL. DA-R, S, T & W [DANDENONG]
Scheduled for Apr 9, 06:00 - 18:00 AEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 23, 2026 - 10:16 AEDT
Scheduled
The water supply to Dandenong campus excluding Buildings R, S, T and W will be interrupted from 6:00am to 6:00pm Thursday 9 April to allow for scheduled maintenance works.
Posted Mar 23, 2026 - 09:25 AEDT
This scheduled maintenance affects: Facilities (Dandenong).