Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 03, 2025 - 07:30 AEDT
Scheduled
Routine maintenance will be undertaken on the automatic doors at Berwick campus from 7:30am to 4:30pm on Thursday 3 April. Contractors will be making their way through the buildings during this period, there may be minor interruptions caused as doors are inspected.
Posted Apr 02, 2025 - 14:39 AEDT
This scheduled maintenance affected: Facilities (Berwick).