Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 01, 2026 - 09:25 AEST
Scheduled
Access to the toilet facilities in Building B at Dandenong campus will be unavailable from 9:30am to 5:00pm Wednesday 1 July to allow for scheduled maintenance works.
Posted Jul 01, 2026 - 09:24 AEST
This scheduled maintenance affected: Facilities (Dandenong).