Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 08, 2026 - 06:00 AEST
Scheduled
Access to Building R at Dandenong campus will be restricted at times from Wednesday 8 April to Friday 17 April to allow for scheduled maintenance works.
NO ACCESS to the EV workshop from Wednesday 8 April to Friday 10 April. NO ACCESS R123, R125 and R126 from Wednesday 8 April to Friday 17 April.
Posted Apr 02, 2026 - 12:40 AEDT
This scheduled maintenance affects: Facilities (Dandenong).