Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 30, 2025 - 07:00 AEST
Scheduled
Planned maintenance on HR Kiosk and Chris21 has been scheduled for Monday 30th June from 7.00am to 9.00am. Both applications will be unavailable during this maintenance window,
Posted Jun 24, 2025 - 16:35 AEST
This scheduled maintenance affected: Systems (Chris21, HR Kiosk).