Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2025 - 16:00 AEDT
Scheduled
The water supply to building H at Berwick campus will be interrupted from 4:00pm Friday 21 March until 9:00am Monday 24 March to allow for scheduled maintenance works.
Posted Mar 21, 2025 - 15:49 AEDT
This scheduled maintenance affected: Facilities (Berwick).