Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 25, 2026 - 06:30 AEDT
Scheduled
Access to the female toilets in A135 at Berwick campus will be unavailable from 6:30am to 4:00pm Wednesday 25 February to allow for scheduled maintenance works. Signage in the area will provide directions to the closest available toilets.
Posted Feb 24, 2026 - 13:21 AEDT
This scheduled maintenance affected: Facilities (Berwick).