Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 05, 2025 - 08:00 AEST
Scheduled
Access to some areas surrounding the new Dandenong car park site will be restricted on Friday 5th September to allow for scheduled construction works: - Pedestrian walkway adjacent to Building C and the Cafeteria courtyard - 8:00am to 12:30pm - Pedestrian walkway adjacent to Building K stairs - 11:30am to 3:00pm. These works will generate some construction noise and dust during this time.
Posted Sep 03, 2025 - 10:28 AEST
This scheduled maintenance affected: Facilities (Dandenong).