Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 29, 2026 - 06:00 AEST
Scheduled
Access to Building P Level 2 at Dandenong campus will be unavailable from 6:00am Monday 29 June to 5:00pm Friday 10 July to allow for scheduled roof maintenance works.
Posted Jun 04, 2026 - 10:59 AEST
This scheduled maintenance affected: Facilities (Dandenong).