Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 02, 2026 - 07:00 AEST
Scheduled
Drainage works will be undertaken to the north of Building G at Frankston campus from 7:00am Tuesday 2 June to 5:00pm Wednesday 3 June. This project may generate some construction noise during this time that may affect occupants of Buildings B, T and W. Please follow all signage in the area to ensure your safety.
Posted Jun 01, 2026 - 09:17 AEST
This scheduled maintenance affected: Facilities (Frankston).