Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 17, 2025 - 06:00 AEDT
Scheduled
Access to the Central car park at Dandenong campus will be unavailable from 6:00am Friday 17 October to 10:00am Monday 20 October to allow for scheduled maintenance works.
Posted Oct 14, 2025 - 16:06 AEDT
This scheduled maintenance affects: Facilities (Dandenong) and Projects (Dandenong new car park).