Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 17, 2026 - 14:35 AEST
Scheduled
Access to the external stairs between Buildings A and P will be unavailable from 2:30pm to 4:00pm Monday 17 August to allow for the installation of lip nosing and tactile to steps. Please follow temporary directional signage in the area.
Posted Aug 17, 2026 - 14:33 AEST
This scheduled maintenance affected: Facilities (Dandenong).