LIFT OUTAGE - CR-A [CRANBOURNE]

Incident Report for chisholm

Resolved

Lift services in Building A have been restored.
Posted Jun 27, 2025 - 08:51 AEST

Identified

Lift services in Building A have been interrupted. The CSI team are working to implement a solution. Further information will be provided as it becomes available.
Posted Jun 24, 2025 - 16:32 AEST
This incident affected: Facilities (Cranbourne).