POWER OUTAGE - [FRANKSTON CAMPUS]
Incident Report for chisholm
Resolved
The power supply to Frankston Campus has been restored. CSI will continue to monitor the system.
Posted Apr 24, 2024 - 15:50 AEST
Identified
The power supply to Frankston Campus has been interrupted due to a power supply interruption. Staff and Students are advised that the campus is CLOSED TODAY, 24 APRIL 2024, please do not attend campus. Updates will be provided as they become available.
Posted Apr 24, 2024 - 07:31 AEST
This incident affected: Facilities (Frankston).